Outil de signature de code

Signez gratuitement des applications Java, Authenticode et Adobe Air

L'outil de signature de code de GlobalSign est un outil intuitif qui permet de signer des applications Java, Windows (noyau et mode utilisateur) et Adobe Air en toute simplicité.

Il suffit, pour cela, de sélectionner le type d'application, le certificat à utiliser et de choisir l'option horodatage dans les cas appropriés. L'outil peut vous demander de télécharger le kit de développement et les outils nécessaires selon l'application choisie. Il affiche ensuite la ligne de commande exécutable qui permet d'accélérer le processus consistant à signer numériquement des applications.

Cet outil est proposé gratuitement afin de faciliter la signature d'applications et de code. Aucune assistance technique ne pourra vous être offerte sur ce produit.

avec Java Web StartExécuter

Si vous possédez Java, veuillez lancer l'application avec Java Web Start.

Sinon, veuillez télécharger le fichier jar et exécutez-le, soit en cliquant deux fois dessus ou en entrant la commande suivante :

java -jar codesigner.jar

Configuration requise

Configuration requise

La version 6 de Java doit être installée

La version 32 bits de Java est préférable car les keystores Windows et Firefox ne fonctionnent pas sous la version 64 bits (le format PKSC#12 sera toujours reconnu).

Signer des applications

Signer des applications

Pour signer des applications Microsoft, il vous faudra signtool.exe qui fait partie de Windows SDK

Pour signer des applications Java, il vous faudra jarsigner qui fait partie de Java JDK (la version 32 bits est recommandée)

Pour signer des applications Adobe AIR, il vous faudra adt qui fait partie de Adobe AIR SDK

Remarques

Remarques

La signature de code GUI ne modifiera en rien votre keystore ou son contenu.

L'utilisation de clés dans le keystore Firefox ne fonctionne que pour les applications Java.

Sur certains systèmes Linux qui utilisent OpenJDK, le jarsigner par défaut peut ne pas fonctionner pour signer certaines applications avec un keystore Firefox ou PKSC#12.

Niveau supérieur

Niveau supérieur

sudo yum install java-1.6.0-openjdk-devel

Ou sudo apt-get install openjdk-6-jdk

Ou essayez Sun Java